CodingBox Q&A Ask question

Synology RS3614xs+ с Intel X520-DA2: allow_unsupported_sfp игнорируется, пока не задан через специфичные для DSM ключи modules.conf

Asked Active Viewed 65 AI translation from English
2

Synology RS3614xs+ с поддерживаемой Intel X520-DA2 отклонял неверно заказанные SFP+ модули как неподдерживаемые. Добавление options ixgbe allow_unsupported_sfp=1 в /etc/modules.conf не давало эффекта, и даже когда в логе ядра появлялась строка ixgbe: allow_unsupported_sfp Enabled, драйвер всё равно сообщал failed to load because an unsupported SFP+ or QSFP module type was detected, что говорит о том, что сборка драйвера Synology или обработка параметров модуля отличается от стандартного Linux.

  • Оборудование: Synology RS3614xs+, Intel X520-DA2
  • Трансиверы: сторонний SFP+, FS.com SFP+
  • Форм-фактор: SFP+

Симптомы/сообщения:

failed to load because an unsupported SFP+ or QSFP module type was detected
ixgbe: allow_unsupported_sfp Enabled but module still rejected

Comments 1

Accepted answer

Задайте ключи в стиле DSM module_ixgbe_args_<platform>="allow_unsupported_sfp=1" (bromolow/broadwell/grantley и общий module_ixgbe_args) как в /etc/modules.conf, так и в /etc.defaults/modules.conf, и используйте первый слот SFP; после этого линк поднялся на 10 Гбит/с. Позже подтверждено с X520-DA2 и трансиверами FS.com.

0 United Kingdomcoaxpilot98GB Show original (English) AI translation
Log in to comment. Log in