CodingBox Q&A Ask question

Synology RS3614xs+ dengan Intel X520-DA2: allow_unsupported_sfp diabaikan sampai di-set lewat key modules.conf khusus DSM

Asked Active Viewed 65 AI translation from English
2

Synology RS3614xs+ dengan Intel X520-DA2 yang didukung menolak modul SFP+ yang salah dipesan sebagai unsupported. Menaruh options ixgbe allow_unsupported_sfp=1 di /etc/modules.conf tidak berefek, dan bahkan ketika kernel log menunjukkan ixgbe: allow_unsupported_sfp Enabled, driver-nya tetap melaporkan failed to load because an unsupported SFP+ or QSFP module type was detected, mengindikasikan build driver Synology atau cara penanganan argumen modulnya beda dari Linux standar.

  • Hardware: Synology RS3614xs+, Intel X520-DA2
  • Transceiver: SFP+ pihak ketiga, SFP+ FS.com
  • Form factor: SFP+

Gejala / pesan:

failed to load because an unsupported SFP+ or QSFP module type was detected
ixgbe: allow_unsupported_sfp Enabled but module still rejected

Comments 1

Accepted answer

Set key bergaya DSM module_ixgbe_args_<platform>="allow_unsupported_sfp=1" (bromolow/broadwell/grantley dan yang generik module_ixgbe_args) di /etc/modules.conf maupun /etc.defaults/modules.conf, dan pakai slot SFP pertama; link-nya lalu naik di 10 Gbps. Dikonfirmasi kemudian dengan X520-DA2 dan transceiver FS.com.

0 United Kingdomcoaxpilot98GB Show original (English) AI translation
Log in to comment. Log in