Synology RS3614xs+ met een Intel X520-DA2: allow_unsupported_sfp wordt genegeerd totdat het in de DSM-specifieke modules.conf-sleutels wordt gezet
Een Synology RS3614xs+ met een ondersteunde Intel X520-DA2 wees de verkeerd bestelde SFP+-modules af als unsupported. Het toevoegen van options ixgbe allow_unsupported_sfp=1 aan /etc/modules.conf had geen effect, en zelfs toen het kernellog ixgbe: allow_unsupported_sfp Enabled liet zien, meldde de driver nog steeds failed to load because an unsupported SFP+ or QSFP module type was detected, wat erop wijst dat Synology's driverbuild of de afhandeling van module-argumenten afwijkt van stock Linux.
- Hardware: Synology RS3614xs+, Intel X520-DA2
- Transceivers: third-party SFP+, FS.com SFP+
- Vormfactor: SFP+
Symptomen / meldingen:
failed to load because an unsupported SFP+ or QSFP module type was detected
ixgbe: allow_unsupported_sfp Enabled but module still rejected
Comments 1
Zet de DSM-stijl-sleutels module_ixgbe_args_<platform>="allow_unsupported_sfp=1" (bromolow/broadwell/grantley en de generieke module_ixgbe_args) in zowel /etc/modules.conf als /etc.defaults/modules.conf, en gebruik de eerste SFP-slot; de link kwam daarna op met 10 Gbps. Later bevestigd met X520-DA2 en FS.com-transceivers.