Intel X520-DA2를 꽂은 Synology RS3614xs+: DSM 전용 modules.conf 키로 설정하기 전까지는 allow_unsupported_sfp가 무시됨
지원 목록에 있는 Intel X520-DA2를 꽂은 Synology RS3614xs+가, 잘못 주문한 SFP+ 모듈을 unsupported로 거부했습니다. /etc/modules.conf에 options ixgbe allow_unsupported_sfp=1을 넣어도 아무 효과가 없었고, 커널 로그에 ixgbe: allow_unsupported_sfp Enabled가 나와도 드라이버는 여전히 failed to load because an unsupported SFP+ or QSFP module type was detected를 보고했습니다. Synology의 드라이버 빌드나 모듈 인자 처리 방식이 표준 Linux와 다른 것으로 보입니다.
- Hardware: Synology RS3614xs+, Intel X520-DA2
- Transceivers: third-party SFP+, FS.com SFP+
- Form factor: SFP+
증상 / 메시지:
failed to load because an unsupported SFP+ or QSFP module type was detected
ixgbe: allow_unsupported_sfp Enabled but module still rejected
Comments 1
DSM 스타일 키인 module_ixgbe_args_<platform>="allow_unsupported_sfp=1"(bromolow/broadwell/grantley 및 범용 module_ixgbe_args)을 /etc/modules.conf와 /etc.defaults/modules.conf 양쪽에 설정하고, 첫 번째 SFP 슬롯을 쓰세요. 그러면 링크가 10Gbps로 올라옵니다. 나중에 X520-DA2와 FS.com 트랜시버로도 확인했습니다.